Covid-19

March 23, 2020, 8:49 PM - Europe/London

Over the last few weeks we’ve been following the emerging Corona Virus outbreak in the news and preparing the company in the event of it escalating further. With the outbreak appearing to spread further we expect these internal preparations to go into effect over the next few weeks.

What does this mean for you as a customer?

To begin with, we expect no immediate changes to setup times, ticket response times or stock procurement. We’ve taken measures internally to guarantee that we have enough general stock for the next few weeks to fulfill any new orders and deal with any emergencies that do arise.

As things progress, we do expect our setup times for new orders and part changes to increase as we try to limit our staff’s exposure to other members of the public, as well any custom builds (ones not listed on our website) to be delayed indefinitely.

During this time we will still have systems in place to deal with emergency callouts and will still have staff active via our ticket system.

As things progress we will make sure to update you and provide you with additional information. Any major changes will be announced via twitter and will be posted on our status page. If you have any questions at all then please open a ticket with our team, we’ll be happy to help.

Locations affected
DDCL / City Reach - London, UKIron Mountain AMS1 - Amsterdam, NLTelehouse North - London, UKEquinix LD8 - London, UKInterxion PAR-5 - Paris, FRInterxion ZUR-1 - Zurich, CHInterxion FRA-15 - Frankfurt, DE
Resolved
Issue now being closed. Operations have continued as usual for last month.

August 18, 2020, 11:31 AM - Europe/London

Update
We just wanted to provide a small update on how we are managing COVID-19 internally and what this means for you. All of our support staff are still working remotely where possible and interaction with on-site staff is limited to stop any chance of passing on infection.

Drive changes and new setups are being carried out at a similar pace to pre-COVID, with new hardware being delivered almost daily. We have replenished the majority of our London stock, however small delays are still expected due to global supply chain issues. We are working to replenish our Amsterdam stock, however with flight restrictions in place and the supply chain issues these are slightly more delayed than London.

Overall the company is up and running as normal now, with many of the current restrictions not affecting us. If you have any questions or queries about services, setup times or possible delays then please let us know.

Zare Team.

June 17, 2020, 3:05 PM - Europe/London

Update
Due to increased quarantine measures within the United Kingdom we will be making changes to our standard deployment and change schedules. All non-emergency changes will now be carried out from 8pm (GMT +0) per day by our staff.

There will be no changes to emergency callouts or ticket response times.

March 23, 2020, 9:37 PM - Europe/London

back to all