Packet loss within Frankfurt, DE [RESOLVED]

March 28, 2026, 1:48 PM - Europe/London

Hello all,

We're currently investigating packet loss and high latency within our Frankfurt, DE location.

Updates to follow shortly.

Thank you for your patience.

Kind regards,
Zare NOC.

Locations affected
Digital Realty FRA-15 - Frankfurt, DE
Resolved
Issue is now resolved, investigation details will be published in the next 24 hours.

March 28, 2026, 4:25 PM - Europe/London

back to all