Power Issue in Zurich, CH [RESOLVED]

May 3, 2026, 7:48 PM - Europe/London

We are aware of a power related issue in one of our racks in Zurich. This is affecting roughly half a rack of services.

We were notified by monitoring at 19:25 BST and a technician was immediately dispatched. They are due onsite at 20:00 BST.

Locations affected
Digital Realty ZUR-1 - Zurich, CH
Resolved
We have successfully moved all devices onto the 63A / 3PH A+B power. This case is now resolved.

Please note you may need to KVM/console via the manager onto your server if its not online.

May 3, 2026, 8:40 PM - Europe/London

Update
We are expediting a migration now onto a 63A / 3PH A+B feed. This will be done one PSU at a time to prevent any further downtime.

May 3, 2026, 8:28 PM - Europe/London

Update
All devices are now powering back online.

May 3, 2026, 8:19 PM - Europe/London

Update
PDU breakers on the lower half of the rack, A and B have tripped. These are being put back online in a controlled manner.

May 3, 2026, 8:04 PM - Europe/London

Update
Technician is now onsite and checking devices/power feeds.

May 3, 2026, 7:59 PM - Europe/London

back to all