Power/Network Issue in Frankfurt, DE [RESOLVED]

June 7, 2026, 7:22 PM - Europe/London

We are currently experiencing an outage in one of our Frankfurt racks in FRA15, DLR.

A technician has been dispatched to visually check the rack for any power related issue. We will continue to provide updates here every 10-15 minutes.

Locations affected
Digital Realty FRA-15 - Frankfurt, DE
Resolved
The switching stack has been rebooted and connectivity has been restored. We will now find the root cause of the issue and report here once we have more information.

June 7, 2026, 8:15 PM - Europe/London

Identified
Power is not the cause of the issue. The primary switch stack that feeds the rack has been identified as the cause and is being rebooted one by one.

All servers will have remained powered on, only network was lost.

June 7, 2026, 8:05 PM - Europe/London

Update
Technician is now at rack diagnosing the source of the power loss

June 7, 2026, 7:52 PM - Europe/London

Update
Technician will shortly be at the rack. An urgent ticket was submitted shortly after we recieved an outage alert.

June 7, 2026, 7:34 PM - Europe/London

back to all