Power outage in Zurich, CH [RESOLVED]

June 25, 2026, 9:50 AM - Europe/London

We are investigating the loss of power to multiple switches and servers in Zurich, CH.

A technician has been dispatched to the facility.

Locations affected
Digital Realty ZUR-1 - Zurich, CH
Resolved
We have migrated A+B power to new PDU's. All servers are back online. We apologize for the downtime.

June 25, 2026, 1:30 PM - Europe/London

Update
Unfortunately, the PDU on the A feed is faulty, we have a spare set we are migrating equipment to now.

June 25, 2026, 12:35 PM - Europe/London

Update
All devices are back online - we are leaving this open as its at-risk still. We are indentifying the underlying issue.

June 25, 2026, 11:54 AM - Europe/London

Update
Digital Realty ZUR1 is experiencing power disruptions to their B feed, likely due to the heatwave across Europe.

Our urgent ticket to DRT hands has not been responded to, likely due to the increased work load. We have already dispatched a third party technician who will be onsite in 20-30 minutes.

June 25, 2026, 10:43 AM - Europe/London

Update
Technician is heading to the rack now. We expect it's a power related issue with a PDU fuse.

The rack is fed by 2x 3PH PDU's with ample power to support all equipment, however 3x switches and multiple blade chassis have lost power entirely.

June 25, 2026, 10:00 AM - Europe/London

back to all